On this page you will find some configuration examples. Please note that we use Sample IP addresses here and you have to adapt these IP addresses accordingly. To see these configuration examples with your tunnel IP addresses, please click on the corresponding symbol in your tunnel overview.
configure terminal
interface Tunnel0
description Securebit IPv6 Tunnel Broker
no ip address
ipv6 enable
ipv6 address 2001:db8:7362::2/64
tunnel source 44.201.72.250
tunnel destination 198.51.100.1
tunnel mode ipv6ip
ipv6 route ::/0 Tunnel0
end
write
auto sbtb-ipv6
iface sbtb-ipv6 inet6 v4tunnel
address 2001:db8:7362::2/64
endpoint 198.51.100.1
local 44.201.72.250
ttl 255
gateway 2001:db8:7362::1
config system sbtb-tunnel
edit "SBTB"
set destination 198.51.100.1
set ip6 2001:db8:7362::2/64
set source 44.201.72.250
next
end
config router static6
edit 1
set device "SBTB"
next
end
ifconfig gif0 create
ifconfig gif0 tunnel 44.201.72.250 198.51.100.1
ifconfig gif0 inet6 2001:db8:7362::2 2001:db8:7362::1 prefixlen 128
route -n add -inet6 default 2001:db8:7362::1
ifconfig gif0 up
interfaces {
ip-0/1/0 {
unit 0 {
tunnel {
source 44.201.72.250;
destination 198.51.100.1;
}
family inet6 {
address 2001:db8:7362::2/64;
}
}
}
}
routing-options {
rib inet6.0 {
static {
route ::/0 next-hop 2001:db8:7362::1;
}
}
}
security {
forwarding-options {
family {
inet6 {
mode packet-based;
}
}
}
}
ifconfig gif0 create
ifconfig gif0 tunnel 44.201.72.250 198.51.100.1
ifconfig gif0 inet6 2001:db8:7362::2 2001:db8:7362::1 prefixlen 128
route -n add -inet6 default 2001:db8:7362::1
/interface 6to4 add comment="Securebit IPv6 Tunnel Broker" disabled=no local-address=44.201.72.250 mtu=1280 name=sbtb remote-address=198.51.100.1
/ipv6 address add address=2001:db8:7362::2/64 advertise=no disabled=no eui-64=no interface=sbtb
/ipv6 route add comment="" disabled=no distance=1 dst-address=2000::/3 gateway=2001:db8:7362::1 scope=30 target-scope=10
ifconfig gif0 tunnel 44.201.72.250 198.51.100.1
ifconfig gif0 inet6 alias 2001:db8:7362::2 2001:db8:7362::1 prefixlen 128
route -n add -inet6 default 2001:db8:7362::1
configure
edit interfaces tunnel tun0
set encapsulation sit
set local-ip 44.201.72.250
set remote-ip 198.51.100.1
set address 2001:db8:7362::2/64
set description "Securebit IPv6 Tunnel"
exit
set protocols static interface-route6 ::/0 next-hop-interface tun0
commit
netsh interface teredo set state disabled
netsh interface ipv6 add v6v4tunnel interface=IP6Tunnel localaddress=44.201.72.250 remoteaddress=198.51.100.1
netsh interface ipv6 add address interface=IP6Tunnel address=2001:db8:7362::2
netsh interface ipv6 add route prefix=::/0 interface=IP6Tunnel nexthop=2001:db8:7362::1